[CIG-SHORT] install PyLith on a 64 bit machine

yaru yaru at earth.sinica.edu.tw
Thu Nov 1 18:43:14 PDT 2007


Hi Brad,
  I have installed proj, numpy, nemesis and FIAT. However, I am not able to
install spatialdata.
I did the following steps to install spatialdata.
$run svn co http://geodynamics.org/svn/cig/cs/spatialdata-0.1/trunk
spatialdata 
$autoreconf -if
$configure
$make
$make install

Please also find attached for config.log. Thank you.

Yaru


-----Original Message-----
From: Brad Aagaard [mailto:baagaard at usgs.gov] 
Sent: Saturday, October 06, 2007 2:04 AM
To: cig-short at geodynamics.org
Cc: yaru
Subject: Re: [CIG-SHORT] install PyLith on a 64 bit machine

Yaru-

Please check to make sure nemesis was installed correctly. You should 
have "nemesis" and "mpinemesis" in $PREFIX/bin.

In section 3.3.2 of the manual, please note that you will also need to
install 
proj (before spatialdata), spatialdata, nemesis, numpy (before FIAT), and 
FIAT. Your linux distribution probably has binary packages for proj and 
numpy.

FIAT is available from http://www.fenics.org/wiki/Download.

The nemesis tarball is posted on the PyLith download page: 
http://www.geodynamics.org/cig/software/packages/short/pylith/.

Spatialdata is also CIG software, but the tarball is not posted on the web 
page. To checkout the source, run
svn co http://geodynamics.org/svn/cig/cs/spatialdata-0.1/trunk spatialdata
You will need to run "autoreconf -if" and "configure" like you do for the
main 
PyLith source.

Brad


On Thursday 04 October 2007, yaru wrote:
> Hi All,
>
>   I try to install PyLith on my 64 bit machine (Operation System :
> Scientific Linux 4.4 64-bit). I successfully install PETSC but fail to
> install PyLith.
>
> When I ran
>  ./configure CXXFLAGS=-DNEW_SECTION --prefix=/data/cig
> I got the following:
> checking for a BSD-compatible install... /usr/bin/install -c checking
> whether build environment is sane... yes checking for gawk... gawk ...
> ......
> ...
> checking for PetscInitialize... yes (C++) checking for petsc.h... yes
> checking whether we can link a trivial C++ PETSc program... yes checking
> for PetscInitialize... yes (C++) checking for PETSc/Sieve... yes
> configure: downloading missing Python dependencies
> configure: error: cannot download missing Python dependencies See
> `config.log' for more details.
>
> I already upgrade Python to v2.5.1.
> The config.log is attached. Could someone help me out?
>
> Thank you,
>
> Yaru
>
> ****************************************************
> Ya-Ju Hsu
> Institute of Earth Sciences, Academia Sinica
> 128 Academia Road, Sec. 2, Nankang,
> Taipei 115, TAIWAN
> e-mail: yaru at earth.sinica.edu.tw
> Tel: 886-2-27839910 ext. 415
> Fax: 886-2-27839871
> ****************************************************

-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: application/octet-stream
Size: 35429 bytes
Desc: not available
Url : http://geodynamics.org/pipermail/cig-short/attachments/20071102/efefb0e6/config-0001.obj


More information about the CIG-SHORT mailing list