<html><head><meta http-equiv="Content-Type" content="text/html charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class="">Dear Hammond, <div class=""><br class=""></div><div class="">Thank you for asking the installation problem.</div><div class=""><br class=""></div><div class="">I made the instruction with Deal II v8.2.1 and I also meet the same problem by using deal II v8.5.</div><div class="">Then, this document becomes outdated instruction.</div><div class=""><br class=""></div><div class="">I am solving this problem, and I also ask if anyone have already install the latest ASPECT with the latest deal ii. on the mailing list.</div><div class=""><br class=""></div><div class="">Have a good weekend,</div><div class="">Hiro.</div><div class=""><br class=""><div><blockquote type="cite" class=""><div class="">2017/11/03 12:53、Hammond, Noah <<a href="mailto:noah_hammond@alumni.brown.edu" class="">noah_hammond@alumni.brown.edu</a>> のメール:</div><br class="Apple-interchange-newline"><div class=""><div dir="ltr" class=""><div class=""><div class="">Hello, I have been following your <a href="https://wiki.geodynamics.org/_media/software:aspect:aspect_yosemite_20150529.pdf" class="">document</a> on how to install ASPECT on Mac OS X. I ran into an error with compiling Aspect and I was wondering if you could help. <br class=""><br class=""></div>I am using Mac OS X El Capitan, 10.11.6.  <br class=""><br class=""></div>After installing Cmake and Deal.II I ran into an error Configuring aspect. It looks like there is a problem with the C compiler but I will include the error message below. I am not very experienced with Cmake so any help would be appreciated. Thanks in advance. Below is the error message:<br class=""><br class="">bash-3.2$ /Applications/CMake.app/Contents/bin/cmake \<br class="">> -D DEAL_II_DIR=/Applications/deal.II.app/Contents/Resources \<br class="">> -D CMAKE_C_COMPILER="mpicc" \<br class="">> -D CMAKE_CXX_COMPILER="mpicxx" \<br class="">> -D CMAKE_CXX_FLAGS="-g -O3 -std=c++11" \<br class="">> -D CMAKE_C_FLAGS="-g -O3" \<br class="">> ../<br class="">-- ====================================================<br class="">-- ============ Configuring ASPECT ====================<br class="">-- ====================================================<br class="">-- Found deal.II version 8.5.0 at '/Applications/deal.II-8.5-brew.app/Contents/Resources/lib/cmake/deal.II'<br class="">-- Using ASPECT_USE_PETSC = 'OFF'<br class="">-- The C compiler identification is AppleClang 7.3.0.7030031<br class="">-- The CXX compiler identification is AppleClang 7.3.0.7030031<br class="">-- Check for working C compiler: /Applications/deal.II.app/Contents/Resources/opt/openmpi-1.6.5/bin/mpicc<br class="">-- Check for working C compiler: /Applications/deal.II.app/Contents/Resources/opt/openmpi-1.6.5/bin/mpicc -- works<br class="">-- Detecting C compiler ABI info<br class="">-- Detecting C compiler ABI info - done<br class="">-- Detecting C compile features<br class="">-- Detecting C compile features - done<br class="">-- Check for working CXX compiler: /Applications/deal.II.app/Contents/Resources/opt/openmpi-1.6.5/bin/mpicxx<br class="">-- Check for working CXX compiler: /Applications/deal.II.app/Contents/Resources/opt/openmpi-1.6.5/bin/mpicxx -- works<br class="">-- Detecting CXX compiler ABI info<br class="">-- Detecting CXX compiler ABI info - done<br class="">-- Detecting CXX compile features<br class="">-- Detecting CXX compile features - done<br class="">-- Setting up test project, see tests/setup_tests.log for details.<br class="">CMake Error at /Applications/CMake.app/Contents/share/cmake-3.10/Modules/CMakeTestCXXCompiler.cmake:45 (message):<br class="">  The C++ compiler<br class=""><br class="">    "/Applications/deal.II-8.5-brew.app/Contents/Resources/brew/bin/mpicxx"<br class=""><br class="">  is not able to compile a simple test program.<br class=""><br class="">  It fails with the following output:<br class=""><br class="">    Change Dir: /Users/noahhammond/src/aspect/build_deal.ii.app/tests/CMakeFiles/CMakeTmp<br class="">    <br class="">    Run Build Command:"/usr/bin/make" "cmTC_65999/fast"<br class="">    /Applications/Xcode.app/Contents/Developer/usr/bin/make -f CMakeFiles/cmTC_65999.dir/build.make CMakeFiles/cmTC_65999.dir/build<br class="">    Building CXX object CMakeFiles/cmTC_65999.dir/testCXXCompiler.cxx.o<br class="">    /Applications/deal.II-8.5-brew.app/Contents/Resources/brew/bin/mpicxx     -o CMakeFiles/cmTC_65999.dir/testCXXCompiler.cxx.o -c /Users/noahhammond/src/aspect/build_deal.ii.app/tests/CMakeFiles/CMakeTmp/testCXXCompiler.cxx<br class="">    make[1]: *** [CMakeFiles/cmTC_65999.dir/testCXXCompiler.cxx.o] Illegal instruction: 4<br class="">    make: *** [cmTC_65999/fast] Error 2<br class="">    <br class=""><br class="">  <br class=""><br class="">  CMake will not be able to correctly generate this project.<br class="">Call Stack (most recent call first):<br class="">  CMakeLists.txt:19 (PROJECT)<br class=""><br class=""><br class="">CMake Error at CMakeLists.txt:178 (MESSAGE):<br class="">  ERROR: Test project could not be configured.<br class=""><br class=""><br class="">-- Configuring incomplete, errors occurred!<br class=""><br class=""> <br class=""></div>
</div></blockquote></div><br class=""></div></body></html>