[CIG-MC] CitcomS installation problem with ggrd

Thorsten Becker thorstinski at gmail.com
Wed Nov 19 10:04:49 PST 2014

No idea why it's not in there, it used to be, I think (though I did just
here about the same problem yesterday!) I attach my current version here. I
hope this will work with your version of HC, the one one the CIG website
hasn't been updated in a while. There's always


which is what I use. Make sure to *not* compile HC with the quad precision
option, that's good for HC (for high L computations), but CitcomS is set up
to interface with the regular, double precision option.



Thorsten W Becker - geodynamics.usc.edu <http://geodynamics.usc.edu/~becker>

On Tue, Nov 18, 2014 at 10:49 PM, A Ghosh <atreig at gmail.com> wrote:

> Hi Thorsten,
>    Thanks for your response. I have installed netcdf, GMT4, HC package
> from cig website and then CitcomS. Basically, I have followed all the
> instructions in the CitcomS manual. The ./configure runs fine and does
> identify the ggrd library, however, the ggrd_handling.h file is not there
> in any of the version of CitcomS that is on the cig website. Any suggestion
> what could be done?
> Thanks
> Attreyee
> On Tue, Nov 18, 2014 at 11:57 PM, Thorsten Becker <thorstinski at gmail.com>
> wrote:
>> You got to install the HC package (also from CIG) which provides those
>> headers and the routines, as well as GMT/Netcdf (do that first). Once
>> installed, the ./configure should pick things up.
>> Cheers
>> T
>> Thorsten W Becker - geodynamics.usc.edu
>> <http://geodynamics.usc.edu/~becker>
>> On Tue, Nov 18, 2014 at 1:39 AM, Attreyee Ghosh <
>> aghosh at ceas.iisc.ernet.in> wrote:
>>> Dear cig,
>>>    I am trying to install CitcomS 3.3.0 on my university cluster. The
>>> installation without ggrd option went fine. However, when I try to install
>>> it with the ggrd option the ./configure ran without any error. But when I
>>> run the Makefile it is looking for  a particular header file in lib called
>>> "ggrd_handling.h", which doesn't seem to exist. I tried to copy that header
>>> file from some other version and tried to run Makefile, but then it's
>>> giving a new suite of errors. Any help will be really appreciated.
>>> Thanks,
>>> Attreyee Ghosh
>>> _______________________________________________
>>> CIG-MC mailing list
>>> CIG-MC at geodynamics.org
>>> http://lists.geodynamics.org/cgi-bin/mailman/listinfo/cig-mc
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.geodynamics.org/pipermail/cig-mc/attachments/20141119/212ff53a/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ggrd_handling.h
Type: text/x-chdr
Size: 2177 bytes
Desc: not available
URL: <http://lists.geodynamics.org/pipermail/cig-mc/attachments/20141119/212ff53a/attachment.h>

More information about the CIG-MC mailing list