[CIG-MC] ssh and autocombine.py

Robert Moucha rmoucha at gmail.com
Wed Nov 4 13:27:15 PST 2009

Hi Eh,

Thanks for getting back to me so quickly. Our cluster is set-up with
password-less ssh into the nodes. I went into
batchcombine.py and added the line print cmd, to see what command was
being executed, here is what I get:
$ autocombine.py mpirun.nodes pid23816.cfg 10

ssh c0-0  pasteCitcomData.py /state/partition1/moucha2/citcoms
cookbook6 coord,velo,visc 0 10

Last login: Wed Nov  4 16:04:40 2009 from geograppe.local
Rocks Compute Node
Rocks 5.0 (V)
Profile built 16:38 16-Jul-2008

Kickstarted 16:50 16-Jul-2008
[moucha at compute-0-0 ~]$

So I tried from my master node:

$ ssh c0-0  pasteCitcomData.py /state/partition1/moucha2/citcoms
cookbook6 coord,velo,visc 0 10

and I get:

bash: pasteCitcomData.py: command not found

Now with the full path:

$ ssh c0-0  ~/software/cig/bin/pasteCitcomData.py
/state/partition1/moucha2/citcoms cookbook6 coord,velo,visc 0 10

It works!  Funny though, because when I log into the node, I can
execute the command directly.  Do you know of a way to solve this
without editing the scripts, or is this just the way ssh works?



On Wed, Nov 4, 2009 at 3:57 PM, Eh Tan <tan2 at geodynamics.org> wrote:
> Hi Robert,
> At some point the script was renamed but the manual was not updated. The
> correct name of the script should be visual/batchcombine.py. Seems you
> have figure it out by yourself.
> Regarding the error message, do you need to type password when ssh into
> the nodes? If so, you will need to setup password-less login first.
> Execute the command "ssh-keygen", and when asked for passphrase, just
> press |<ENTER>| twice. Then try autocombine.py again.
> Eh
> Robert Moucha wrote:
>> Hi All,
>> Our cluster uses ssh instead of rsh. I followed the 3.1.1 manual instructions:
>> "If your Beowulf cluster uses ssh (rather than rsh) to access the
>> computation nodes, you must manually edit
>> visual/batchpaste.sh and replace ‘rsh’ with ‘ssh’ in the script."
>> However there is no batchpaste.sh in this directory.  I only have:
>> getcoord.sh  getlog.sh  getsurf.sh
>> I went into these and changed rsh to ssh, I also went into
>> batchcombine.py and changed it to ssh.
>> Now when I run autocombine.py I get logged into the first node on the
>> list and nothing happens. I type exit and I get an error
>> Traceback (most recent call last):
>>   File "/home/moucha/software/cig/bin/pasteCitcomData.py", line 172, in ?
>>     run(datadir, datafile, fields, rank, step, save_dir)
>>   File "/home/moucha/software/cig/bin/pasteCitcomData.py", line 53, in run
>>     paste(datadir, datafile, fields, rank, step, f)
>>   File "/home/moucha/software/cig/bin/pasteCitcomData.py", line 68, in paste
>>     f = open_file(datadir, datafile, infix, rank, step)
>>   File "/home/moucha/software/cig/bin/pasteCitcomData.py", line 115,
>> in open_file
>>     f = open(filename, 'r')
>> IOError: [Errno 2] No such file or directory:
>> '/state/partition1/moucha2/citcoms/cookbook6.coord.0'
>> and I log into the next node on list,  this goes on and on through all
>> the nodes in my machine list.  By the way, the files do exist on these
>> nodes.
>> Thanks, again,
>> Rob
> --
> Eh Tan
> Staff Scientist
> Computational Infrastructure for Geodynamics
> California Institute of Technology, 158-79
> Pasadena, CA 91125
> (626) 395-1693
> http://www.geodynamics.org

GEOTOP - Département des Sciences de la Terre et de l'Atmosphère
Université du Québec à Montréal
CP 8888, succursale Centre-Ville
Montréall, Québec
Canada  H3C 3P8
Tel:     (1-514) 987-3000, ext 1554#
FAX:     (1-514) 987-3635

More information about the CIG-MC mailing list