[CIG-MC] cookbook 9 problem

Eh Tan tan2 at geodynamics.org
Tue Mar 3 14:53:24 PST 2009

Hi Clint,
(cc to cig-mc)

The problem is that ExchangerLib was compiled, but not linked to
mpipycitcoms. I don't know exact cause of it.  Maybe the time stamp of
the files were messed up. A forced relinking fixes the problem.


> Eh,
> I tried the first command and got an error:
> [clintc at akua ~/citcom]$ mpipycitcoms -c "import ExchangerLib"
> Traceback (most recent call last):
>   File "<string>", line 1, in ?
> ImportError: No module named ExchangerLib
> Next, I tried the second command (in the CitcomS-3.0.3 directory) and
> something compiled (there was a long output).
> Then, I tried the first command again and it worked (no output):
> [clintc at akua CitcomS-3.0.3]$ mpipycitcoms -c "import ExchangerLib"
> [clintc at akua CitcomS-3.0.3]$ 
> Then, I tried to run cookbook9 again, in the same way I did before,
> and now cookbook9 is running normally. So apparently I needed to run
> the 2nd command to get this to work. I have to admit, I do not
> understand why!
> So I'm kind of amazed - but this is great! Thanks a lot for your help!
> When you have time, could you tell me what I did wrong in the first
> place??
> Clint
> On Mar 3, 2009, at 11:26 AM, Eh Tan wrote:
>> Hi Clint,
>> Can you try this command:
>> $ mpipycitcoms -c "import ExchangerLib"
>> If this gives you an error, can you send me the result of this command?
>> $ touch bin/pycitcoms.c; make
>> Eh

Eh Tan
Staff Scientist
Computational Infrastructure for Geodynamics
California Institute of Technology, 158-79
Pasadena, CA 91125
(626) 395-1693

More information about the CIG-MC mailing list